Error trying to run deploy_account

After I run starknet new_account I get

Account address: 0x0374fa75d584acfb74c9680662f75cbab21411210171c943fab4e60f1859d1f8
Public key: 0x03b904a34b9872e6f6901c6450644fc756c25cc1338766c3ba26cae5dedf3c69

I use the faucet at https://faucet.goerli.starknet.io/ to successfully get some test ETH, but when
running starknet deploy_account --simulate I get the error

Got BadRequest while trying to access https://alpha4.starknet.io/feeder_gateway/simulate_transaction?blockNumber=pending&skipValidate=false. Status code: 500; text: {"code": "StarknetErrorCode.UNDECLARED_CLASS", "message": "Class with hash 0x6ea5324f5d3f919a7ff007acfad6c421d724cf0cbcf0f6105945565518a572 is not declared."}.

which seems to imply it is not seeing any funds in the account. I also tried transferring thru Starkgate from my Goerli to a new ArgentX wallet and then sending some testnet ETH to the address. I can see in Starkscan there are funds there at Contract - Starkscan
What is the mistake I am making in being able to deploy the contract address as per instructions I am following at Setting up a StarkNet account — Cairo documentation
Any help is appreciated.
Thanks

Hello bro, I’ll try to help you.
First of all what wallet are you using > Argentx or myBraavos?
Secondly, did you update your wallets recently? Cause myBraavos wallet had big update recently, and for users who didn’t update in time, might be some issues with account > For full info better to check myBraavos’s Discord server.

Via starkcan I saw that you deployed your account year ago, and if you didn’t update your account on time (were few updates), u might loose an access to your account, which means you need to create your wallet again

Hey, my ArgentX wallet was created today, as was the “test” account from the command line (using starknet new account command following the instructions). Not sure if you’re reading starkscan correctly, all my transactions happened today.

What happens if you try sending any assets from the wallet to, for example, same address?
Are you facing any errors, if yes which error are you facing?

I’ll try to figure it out :thinking:
But at the same time recommend you to visit ArgetX’s Discord, Devs can provide qualified help to you :heart_hands:

I am following the setup page at Setting up a StarkNet account — Cairo documentation so I don’t have a “wallet” to send and receive from, I am simply using the CLI with ‘starknet’ commands as the guide progresses. ArgentX is a totally separate testnet wallet, not used for development. The issue I am having is with the development tutorial in trying the steps from the page to setup an account, I cannot run starknet deploy_account even after sending Goerli ETH for gas to the testnet wallet address that was generated.

Oh, I see then. I’m not super prof in tech stuff, but suggest you to enter Starknet Discord, there’re many devs in the Discord server, u can find answer to your question very fast :heart_hands: